DONATION STATUS
Needed before 2016-12-31
$ 2,500
So far donated
$ 755

problem with links

Discussion in 'Announcements' started by pianolady, Oct 2, 2007.

  1. pianolady

    pianolady Monica Hart, Administrator Staff Member Piano Society Artist

    Joined:
    Jun 14, 2006
    Messages:
    8,712
    Likes Received:
    1
    Last Name:
    Hart
    First Name:
    Monica
    I just went over to listen to some Grieg pieces and noticed that the links to most of them take you back to the home page. (Maybe all of them but I have to go to work now and don't have time to check.) Perhaps it's because there was a problem with the site today?
     
  2. robert

    robert New Member Piano Society Artist

    Joined:
    Jun 7, 2006
    Messages:
    1,842
    Likes Received:
    0
    Location:
    Sweden
    Home Page:
    Last Name:
    Stahlbrand
    First Name:
    Robert
    WEBSITE:
    http://pianosociety.com
    WLM:
    robertstahlbrand@hotmail.com
    LOCATION:
    Sweden
    The reason was the downtime problems we had today (disc sync failure, really hope it was a one time event). I was just editing the hotlink protection when it went down. I have fixed it now.

    What I have implemented but which did not work from properly was a restriction so that people could not link recordings from pianosociety from their site (bandwidth theft). I have reconfigured this protection and it now works. Check this site out which links to your famous Brahms op.118 Arensky:
    http://www.c-player.com/ac32191/message ... ormat=time

    Now when you press the mp3-links, it simply takes you to the main page instead :).

    At the same time, I have implemented another feature which does not make it possible to just type the URL in your browser or favorite player. If you do, you also end up on the main page. Why? Of course we want our visitors to go to the site before downloading don't we? I mean, so they care read our bios and stuff. I am certain I will get many complaints from people putting up play lists in iTunes and similar streamers. But this is exactly how I want it! :twisted:
     
  3. pianolady

    pianolady Monica Hart, Administrator Staff Member Piano Society Artist

    Joined:
    Jun 14, 2006
    Messages:
    8,712
    Likes Received:
    1
    Last Name:
    Hart
    First Name:
    Monica
    No links are working on my computer. It is not taking me to the home page like before, but it opens my media player and then gives me the following error message:

    *****Windows Media Player cannot play the file. The Player might not support the file type or might not support the codec that was used to compress the file.*****


    It's not a problem with the player because my saved files on my computer do work.

    Is anyone else having trouble?
     
  4. pianolady

    pianolady Monica Hart, Administrator Staff Member Piano Society Artist

    Joined:
    Jun 14, 2006
    Messages:
    8,712
    Likes Received:
    1
    Last Name:
    Hart
    First Name:
    Monica
    Never mind. It was Windows Media Player ruining my life, again. Now I'm using Quicktime and itunes and links are working again. :D :D
     
  5. pianolady

    pianolady Monica Hart, Administrator Staff Member Piano Society Artist

    Joined:
    Jun 14, 2006
    Messages:
    8,712
    Likes Received:
    1
    Last Name:
    Hart
    First Name:
    Monica
    Now I'm sure that aliens have taken over my computer. For the past two hours I tried to log on but got that kind of critical error message. Can't remember what it said exactly, but all I got was a white screen with three or four lines of code stuff and something about critical errors. But I think I'm the only one, as I see other members posted earlier with no problems.
    I need to get off this computer!
     
  6. robert

    robert New Member Piano Society Artist

    Joined:
    Jun 7, 2006
    Messages:
    1,842
    Likes Received:
    0
    Location:
    Sweden
    Home Page:
    Last Name:
    Stahlbrand
    First Name:
    Robert
    WEBSITE:
    http://pianosociety.com
    WLM:
    robertstahlbrand@hotmail.com
    LOCATION:
    Sweden
    There was a serious problem which perhaps caused tables in the database to corrupt. But at 1:45 am (MET+1), I run a script which does a database-fix-it-all which probably took care of the problem. I see no problems now.
     
  7. Anonymous

    Anonymous Guest

    FYI
    The link : COMPOSERS> Chopin > Waltzes > "Waltz No.16 in A flat major" ( 2:16 by Assimakopoulos, P.)
    points to a wrong file: "chopin-ph-waltz-14-morin-paul.mp3"
     
  8. techneut

    techneut Active Member Piano Society Artist

    Joined:
    Jun 12, 2006
    Messages:
    9,930
    Likes Received:
    0
    Location:
    Netherlands
    Last Name:
    Breemer
    First Name:
    Chris
    LOCATION:
    Netherlands
    Indeed so ! I have corrected it.
    Thanks for reporting this, we appreciate all feedback on errors.
     
  9. Terez

    Terez New Member

    Joined:
    Apr 30, 2007
    Messages:
    1,418
    Likes Received:
    0
    Occupation:
    Student
    Location:
    Gulfport, MS, USA
    WLM:
    terez2727@hotmail.com
    AOL:
    terez2727
    LOCATION:
    Gulfport, MS, USA
    Since non-admin people can't start threads here, I hijacked this one. I'm not sure if you guys are aware of it, but the PS banner no longer links to the home page - it instead links to the forum index, which is not only redundant as we already have the Board Index link on every, but means that there is no easy link to the home page from the forums. Not a problem really for people who maintain bookmarks, but I get the feeling that it is supposed to link to the home page.
     
  10. techneut

    techneut Active Member Piano Society Artist

    Joined:
    Jun 12, 2006
    Messages:
    9,930
    Likes Received:
    0
    Location:
    Netherlands
    Last Name:
    Breemer
    First Name:
    Chris
    LOCATION:
    Netherlands
    Thanks, I had never noticed that ! Doesn't make much sense indeed. I guess it has been like this ever since
    the new forum was created.
    However, I can't work out how to change this... Been digging around in the configuration and files but to no avail.
    So I gave up !
     

Share This Page